Polygon Mainnet: Archive RPC Degraded Performance

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Jan 26, 2026 - 00:28 UTC

Update

We are continuing to monitor for any further issues.
Posted Jan 25, 2026 - 23:33 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 25, 2026 - 23:32 UTC

Investigating

We are investigating intermittent 503 errors affecting Polygon (Matic) Mainnet Archive RPC. Some customers may experience temporary request failures or degraded performance.

Our team is actively working to mitigate the issue and restore full service stability.

We will provide an update as more information becomes available.
Posted Jan 25, 2026 - 20:22 UTC
This incident affected: Polygon (Mainnet — JSON-RPC API, Mainnet — Websockets API, Mainnet — Webhooks, Mainnet — Streams).