HyperEVM Testnet Degraded Performance

Incident Report for Quicknode

Resolved

The issue affecting HyperEVM Testnet has been resolved. 503 errors have cleared and all systems are operating normally. We will continue to monitor for any recurrence.
Posted Jun 10, 2026 - 01:20 UTC

Monitoring

We are monitoring HyperEVM Testnet for continued stability and will provide further updates as needed.
Posted Jun 10, 2026 - 00:53 UTC

Investigating

The QuickNode team is investigating degraded performance of HyperEVM Testnet - we will update this page as we acquire new information.
Posted Jun 10, 2026 - 00:45 UTC
This incident affected: HyperLiquid (HyperEVM-Testnet - JSON-RPC API).