XRPLEVM Stalled at block 4,748,999

Incident Report for Quicknode

Resolved

The issue affecting the XRPL EVM network, which caused the chain to stall at block 4,748,999, has been fully resolved. The network is now operating normally and blocks are progressing as expected.

Our team has confirmed stability and will continue to monitor the network closely.

We appreciate your patience while we worked to resolve this incident.
Posted Mar 02, 2026 - 17:01 UTC

Investigating

We are currently investigating an incident affecting the XRPL EVM network. Our team is actively working on identifying the root cause and implementing a resolution. Further updates will be shared as soon as more information becomes available.
Posted Mar 02, 2026 - 13:33 UTC
This incident affected: XRP Ledger (Mainnet — JSON-RPC API, Mainnet — Websockets API, Mainnet — Streams, Mainnet — Webhooks).