Degraded Performance - TON Mainnet

Incident Report for Quicknode

Resolved

Service has stabilized, and 503s are back down significantly.

We are still coordinating with the TON Foundation on an upstream release that provides a permanent fix, and we will roll it out once available. We will continue to monitor closely and will post a new update if impact returns or when the Foundation release is deployed.
Posted May 19, 2026 - 15:21 UTC

Monitoring

Nodes have stabilized and 503s are down significantly. We're working with the foundation on a permanent fix.
Posted May 11, 2026 - 22:16 UTC

Investigating

The QuickNode team is investigating the degraded performance of TON Mainnet. We will update this page as we acquire new information. Users may experience 503s at this time.
Posted May 11, 2026 - 20:19 UTC
This incident affected: TON (Beta) (Mainnet — REST API).