[Standard] Scheduled: XRP Mainnet and Testnet - Upgrade Clio to v2.5.0

Scheduled for Aug 12, 19:00 - 21:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Aug 12, 2025 - 19:00 UTC

Scheduled

We will be upgrading our rippled nodes on both XRPL Mainnet and Testnet to clio version v2.5.0 on 2025-08-12 at 19:00 UTC.

**Client Updates:**
• clio: Upgrading to v2.5.0

**Release Notes Summary:**
**XRP Ledger Protocol Updates:**
• Added support for new amendments: Batch, Permission Delegation, Permissioned DEX, and Token Escrow
• Enhanced CTID (Canonical Transaction ID) support across all RPC methods that include transactions

**API Enhancements:**
• Added account permission support for RPC calls
• Improved account_lines RPC method with corrected ripple_flag logic
• Enhanced book_changes RPC method to include domain information

**Additional Information:**
• Release notes: https://github.com/XRPLF/clio/releases/tag/2.5.0
Posted Aug 12, 2025 - 19:00 UTC
This scheduled maintenance affects: XRP Ledger (Mainnet — JSON-RPC API, Mainnet — Websockets API, Testnet — JSON-RPC API, Testnet — Websockets API).