Degraded Performance - Race Mainnet

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Oct 05, 2025 - 21:22 UTC

Monitoring

Race Mainnet nodes are progressing once again and have synced to the tip of the chain. We are monitoring performance to ensure stability and will provide an update upon confirmation or if further action is required within 10 minutes.
Posted Oct 05, 2025 - 21:12 UTC

Investigating

The QuickNode team is investigating the degraded performance of our Race Mainnet nodes.
You may see stuck block height and or increase in errors while we work with the Race chain team on a solution.

We will update this page as we acquire new information, with an update by 22 UTC.
Posted Oct 05, 2025 - 19:08 UTC