XRP Mainnet: Block height stalled at 101633015

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Jan 18, 2026 - 05:04 UTC

Monitoring

Our engineers have implemented a fix, and we are actively monitoring to ensure stability.
Posted Jan 18, 2026 - 02:54 UTC

Investigating

XRP Mainnet is stalled at block 101,633,015. The Quicknode team is investigating and will update with more information once available.
Posted Jan 18, 2026 - 00:19 UTC
This incident affected: XRP Ledger (Mainnet — JSON-RPC API, Mainnet — Websockets API, Mainnet — Streams, Mainnet — Webhooks).