Polygon Amoy : Degraded performance with archive calls

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Jun 18, 2025 - 15:51 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 18, 2025 - 15:33 UTC

Identified

The degraded performance issue is related to the node client. We are currently working with the Erigon team on this issue.
https://github.com/erigontech/erigon/issues/15572
Posted Jun 15, 2025 - 01:55 UTC

Investigating

We are currently investigating an issue causing degraded performance on the archive node infrastructure. Our engineering team is actively working to identify the root cause and restore full functionality as quickly as possible. We appreciate your patience and apologize for the inconvenience.
Posted Jun 13, 2025 - 20:30 UTC
This incident affected: Polygon (Amoy — JSON-RPC API, Amoy — Websockets API, Amoy — Webhooks, Amoy — Streams).