Avalanche Mainnet: Degraded performance

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Oct 05, 2025 - 22:24 UTC

Monitoring

Avalanche nodes have recovered, and we are continuing to monitor.
All customers should now be receiving expected responses from endpoint requests on Avalanche Mainnet.
We will provide an update upon confirmation of stability or if further action is required within 10 minutes.
Posted Oct 05, 2025 - 22:13 UTC

Investigating

We recently identified a spike in 503 errors on Avalanche Mainnet. Our team is working to recover our nodes and will share another update within the next 30 minutes.
Posted Oct 05, 2025 - 22:04 UTC
This incident affected: Avalanche (Mainnet — JSON-RPC API, Mainnet — WebSocket API, Mainnet — Webhooks, Mainnet — Streams).