Degraded Performance - Flow Mainnet

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted Oct 23, 2025 - 04:12 UTC

Monitoring

503 errors on the FlowEVM API have been mitigated, and the service is now performing normally.
We are continuing to monitor the service to ensure full capacity.

We will provide our next update by 05:00 UTC or sooner.
Posted Oct 23, 2025 - 03:59 UTC

Investigating

The FlowEVM API is currently experiencing degraded performance, and you may see 503 errors when making requests.
We are working closely with the Flow team to resolve the issue.

We will provide our next update by 05:00 UTC or sooner.
Posted Oct 23, 2025 - 03:36 UTC
This incident affected: Flow (Mainnet — REST API).