Polygon Amoy Testnet - Elevated 503 Errors During Load Testing

Incident Report for Quicknode

Resolved

The elevated 503 errors on Polygon Amoy Testnet observed during the scheduled load testing window (19:00–20:00 UTC) have subsided. The incident has been resolved and all systems are operating normally.
Posted May 20, 2026 - 20:29 UTC

Investigating

We are aware of elevated 503 errors on the Polygon Amoy Testnet. This is related to scheduled load and stress testing being conducted by the Polygon team between 19:00 – 20:00 UTC. We will update this page as more information becomes available.
Posted May 20, 2026 - 19:34 UTC
This incident affected: Polygon (Amoy — JSON-RPC API, Amoy — Websockets API, Amoy — Webhooks, Amoy — Streams).