Degraded Performance - Litecoin Testnet

Incident Report for Quicknode

Resolved

The QuickNode team has completed the investigation and the performance has now returned to normal.
We will continue to monitor for any performance issues. Please let us know if you experience any further issues.
Posted Feb 24, 2026 - 17:06 UTC

Investigating

The QuickNode team is investigating the degraded performance of Litecoin Testnet
You may see increased response times or timeouts while we work to resolve this incident.
We will update this page as we acquire new information.
Posted Feb 24, 2026 - 15:48 UTC
This incident affected: Litecoin (Testnet - JSON RPC API).