Stacks testnet : Node infrastructure has stalled at 154171
Incident Report for QuickNode
Resolved
This incident has been resolved.
Posted Apr 23, 2024 - 00:32 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 22, 2024 - 06:28 UTC
Identified
An ongoing Bitcoin block storm seems to have impacted Testnet block production.
We're closely listening to updates from the foundation team.

https://status.hiro.so/incidents/btqfvhmg7rry
Posted Apr 17, 2024 - 07:00 UTC
Investigating
We are currently investigating this issue.
Posted Apr 17, 2024 - 05:00 UTC
This incident affected: Stacks (Testnet — JSON-RPC API, Testnet — Websockets API).