Solana Mainnet - Urgent Middleware Maintenance

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Feb 11, 2026 - 17:45 UTC

Monitoring

Maintenance has been completed, we are monitoring for performance.
Posted Feb 11, 2026 - 17:30 UTC

Investigating

We are performing urgent middleware maintenance on our Solana infrastructure.
You may see heightened response times on some methods during this maintenance, which will resolve when the work is finished.

Users may want to raise timeouts on RPC requests during this time.
Posted Feb 11, 2026 - 17:15 UTC
This incident affected: Solana (Mainnet — JSON-RPC API, Mainnet — Websockets API).