Flare Mainnet Degraded Performance

Incident Report for Quicknode

Resolved

The 503 errors affecting Flare Mainnet have been resolved and all systems are operating as expected. We will continue to monitor for stability.
Posted Jul 29, 2026 - 17:09 UTC

Monitoring

The 503 errors on Flare Mainnet have been resolved. We are monitoring the service for continued stability and will provide further updates as needed.
Posted Jul 29, 2026 - 15:23 UTC

Investigating

The Quicknode team is investigating the degraded performance of Flare Mainnet - we will update this page as we acquire new information.
Posted Jul 29, 2026 - 15:15 UTC
This incident affected: Flare (Mainnet).