Starknet Testnet (Sepolia): Degraded Block Production

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Mar 20, 2026 - 22:12 UTC

Identified

We are currently aware of a network-wide issue affecting Starknet Testnet (Sepolia), where block production has significantly slowed down.

This is a broader infrastructure issue being handled by the Starknet Foundation. We are actively monitoring the situation and will provide updates as new information becomes available.

Starknet Status Page: https://status.starknet.io/incidents/896s468434dk
Posted Mar 20, 2026 - 19:40 UTC
This incident affected: Starknet (Sepolia — JSON-RPC API, Sepolia — Websockets API).