Stuck Network - Solana Devnet

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Apr 14, 2026 - 15:36 UTC

Monitoring

Some nodes have recovered, and 503s have been mitigated. Quicknode teams are continuing to work to recover full capacity and monitor performance to ensure stability.
Posted Apr 14, 2026 - 07:42 UTC

Identified

The QuickNode team is currently following the foundation team's guidance to recover the nodes and will provide further updates as more information becomes available.
Posted Apr 14, 2026 - 05:00 UTC

Investigating

Solana Devnet is currently stalled at block 455,406,479. This has been confirmed as a network-wide issue and is expected, according to the foundation team. QuickNode is awaiting further guidance and will provide updates as more information becomes available.
Posted Apr 14, 2026 - 04:30 UTC
This incident affected: Solana (Devnet — JSON-RPC API, Devnet — Websockets API, Devnet — Webhooks, Devnet — Streams).