Stacks Testnet: Block Height Stalled at 3,959,436

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Apr 19, 2026 - 22:34 UTC

Investigating

We are currently investigating this issue. Users requesting data beyond this block will experience 503s. The Quicknode team is investigating and will update with more information once it is available.
Posted Apr 18, 2026 - 22:52 UTC
This incident affected: Stacks (Testnet — REST API, Testnet — Websockets API).