Degraded Performance on US-EAST region

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Jul 07, 2026 - 18:39 UTC

Monitoring

The degraded performance issue has been mitigated. The Quicknode team is continuing to monitor performance to ensure stability.
Posted Jul 07, 2026 - 08:10 UTC

Identified

The Quicknode team has identified the degraded performance issue in the US-EAST region. This issue should have been mitigated. We are actively monitoring this and will provide an update as we acquire new information.
Posted Jul 07, 2026 - 06:32 UTC

Investigating

The Quicknode team is investigating the degraded performance in the US-EAST region.
You may see increased error rates, response times, or timeouts while we work to resolve this.
We will provide an update as more information becomes available.
Posted Jul 07, 2026 - 05:59 UTC