Flow Network - Network Halt Due to Security Investigation

Incident Report for Quicknode

Update

The Flow EVM Gateway for transactions is currently unavailable but is expected to be back online within the next 24-48 hours, according to the Flow Foundation team.


- https://status.flow.com/incidents/v7p5zjvjy87j


Next update by 20:00 UTC, December 30, 2025, or sooner as information becomes available.
Posted Dec 30, 2025 - 07:23 UTC

Monitoring

The Flow Mainnet network upgrade is now complete, and Flow mainnet is back online on Mainnet-28.

The block start height is: 137390146. The Flow EVM Gateway for transactions is not yet available, but should be back online in the next 24-48 hours according to the Flow chain team.

For official updates, please monitor: https://x.com/flow_blockchain/status/2004894914543571022?s=20
Next update by 20:00 UTC, December 30, 2025, or sooner as information becomes available.
Posted Dec 29, 2025 - 16:30 UTC

Update

We are continuing to experience service disruptions on Flow due to an upstream network issue. While there is no significant change in status, we remain in close coordination with the Flow Foundation as they work to resolve this matter.

The Flow Foundation is investigating a potential security incident and halted the network to ensure user assets remain safe. All Flow RPC endpoints are currently unavailable due to this network halt, and transactions cannot be processed until the Flow network resumes operations. The QuickNode team is actively collaborating with the Foundation and following their instructions to upgrade nodes in preparation for network resumption.

For official updates, please monitor: https://x.com/flow_blockchain/status/2004894914543571022?s=20

Next update by 20:00 UTC, December 29, 2025, or sooner as information becomes available.
Posted Dec 29, 2025 - 14:25 UTC

Identified

We are currently experiencing service disruptions on Flow due to an upstream issue with the Flow network. The Flow Foundation is investigating a potential security incident and has halted the network to ensure user assets remain safe.

All Flow RPC endpoints are currently unavailable due to the upstream network halt. Transactions cannot be processed until the Flow network resumes.

The quicknode team is actively collaborating and following the instructions from the foundation team to upgrade nodes.

For official updates, please monitor: https://x.com/flow_blockchain/status/2004894914543571022?s=20

Next update: by 15:00, 12/29 UTC or sooner as information becomes available.
Posted Dec 28, 2025 - 06:50 UTC

Investigating

We are currently experiencing service disruptions on Flow due to an upstream issue with the Flow network. The Flow Foundation is investigating a potential security incident and has halted the network to ensure user assets remain safe.

All Flow RPC endpoints are currently unavailable due to the upstream network halt. Transactions cannot be processed until the Flow network resumes.

The Flow Foundation is actively collaborating with network partners and relevant authorities to address the issue. We will provide further updates as soon as verified information becomes available from the Flow Foundation.

For official updates, please monitor: https://x.com/flow_blockchain/status/2004894914543571022?s=20

Next update: by 04:00, 12/28 UTC or sooner as information becomes available.
Posted Dec 27, 2025 - 14:52 UTC
This incident affects: Flow (Mainnet — REST API, gRPC, Mainnet — Webhooks, Mainnet — Streams).