Urgent Solana-Mainnet v2.1.21 Patch

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted Apr 19, 2025 - 23:12 UTC

Identified

Core Solana contributors have identified a network security issue that requires an urgent response. Version 2.1.21 with a critical security patch going live in all regions. During the upgrade process, you may experience temporary service degradation and intermittent 503 Service Unavailable errors which are expected and should resolve once upgrades are complete.
Posted Apr 18, 2025 - 23:44 UTC
This incident affected: Solana (Mainnet — JSON-RPC API, Mainnet — Websockets API, Mainnet — Streams).