Solana Mainnet - Degraded Performance

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted Sep 10, 2025 - 19:35 UTC

Update

We are continuing to monitor for any further issues.
Posted Sep 10, 2025 - 18:18 UTC

Monitoring

503 mitigated, our engineering team continues to monitor for efficacy heading towards a full resolution.
Posted Sep 10, 2025 - 16:53 UTC

Investigating

We are investigating the degraded performance issue on the Solana mainnet, which may intermittently cause 503 errors.
As we progress toward a resolution, expect the next update on or before 17:00 UTC.
Posted Sep 10, 2025 - 16:21 UTC
This incident affected: Solana (Mainnet — JSON-RPC API, Mainnet — Websockets API, Mainnet — Streams).