Degraded Performance - Polygon Amoy

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted May 07, 2026 - 23:08 UTC

Identified

The Quicknode team is aware of the degraded performance of the Polygon Amoy Network. The foundation has notified us they are performing stress tests on the network. Users may experience elevated latencies, timeouts, and 503 errors at this time.
Posted May 07, 2026 - 20:47 UTC
This incident affected: Polygon (Amoy — JSON-RPC API, Amoy — Websockets API, Amoy — Webhooks, Amoy — Streams).