Race Mainnet: Block Height Stalled at 18,629,394

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted Sep 12, 2025 - 14:05 UTC

Monitoring

Nodes are producing new blocks again. We will keep monitoring this situation.
Posted Sep 12, 2025 - 13:47 UTC

Investigating

We are currently investigating this issue.
We expect to provide an update in the next 30 mins.
Posted Sep 12, 2025 - 13:31 UTC
This incident affected: RACE (Mainnet — JSON-RPC API, Mainnet — Websocket API).