Degraded Performance - Multiple Chains

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Jul 29, 2026 - 20:19 UTC

Monitoring

The elevated 503 errors have been mitigated and our team is actively monitoring for stability.
Posted Jul 29, 2026 - 19:37 UTC

Update

The Quicknode team is investigating degraded performance affecting multiple regions. At the moment, users may experience 503s and elevated errors on Solana archive requests. 503s affecting other chains have been mitigated and our team is actively working to restore full service.
Posted Jul 29, 2026 - 19:30 UTC

Investigating

The Quicknode team is investigating degraded performance affecting multiple chains - we will update this page as we acquire new information.
Posted Jul 29, 2026 - 19:16 UTC