Hyperliquid network stuck at block 5219420

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted Jun 08, 2025 - 12:15 UTC

Investigating

The HyperEVM chain is stuck at 5219420, we're in contact with the Foundation to resolve this asap
Posted Jun 08, 2025 - 10:07 UTC
This incident affected: HyperLiquid (HyperLiquid Mainnet - JSON-RPC API, HyperLiquid Mainnet - Websockets API).