Arc Testnet Degraded Performance

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Sep 22, 2026 - 02:00 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 22, 2026 - 01:24 UTC

Update

We are continuing to investigate on the issue.
Posted Sep 22, 2026 - 00:49 UTC

Investigating

The Quicknode team is investigating the degraded performance of Arc Testnet. Users may experience 503 errors at this time. We will update this page as we acquire new information.
Posted Sep 21, 2026 - 21:43 UTC
This incident affected: Arc (Arc Testnet - JSON RPC API, Arc Testnet - Websocket API).