Sui Mainnet - Archive Degraded Performance

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Aug 01, 2026 - 20:56 UTC

Monitoring

The degraded performance has resolved and we are monitoring for stability.
Posted Aug 01, 2026 - 15:15 UTC

Investigating

The Quicknode team is investigating the degraded performance of Sui Mainnet archive nodes - we will update this page as we acquire new information.
Posted Aug 01, 2026 - 14:55 UTC
This incident affected: Sui (SUI Mainnet — gRPC / JSON-RPC API, Sui Mainnet - gRPC, Sui Mainnet - GraphQL).