Urgent: Ethereum Mainnet & Sepolia & Hoodi – Mandatory Geth Security Upgrade

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Jan 14, 2026 - 16:00 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jan 14, 2026 - 14:08 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jan 14, 2026 - 13:30 UTC

Identified

We are performing a mandatory security upgrade across all Ethereum networks.
The update addresses a security issue on the peering networking on the Geth client.

No downtime is expected, but customers may experience brief connection interruptions and a small number of HTTP 503 responses as services restart and resynchronize with the network.

Geth: Moisture Filters (v1.16.8)
https://github.com/ethereum/go-ethereum/releases/tag/v1.16.8
Posted Jan 14, 2026 - 12:38 UTC
This incident affected: Ethereum (Mainnet — JSON-RPC API, Mainnet — Websockets API, Sepolia — JSON-RPC API, Sepolia — Websockets API, Hoodi - JSON-RPC API, Hoodi - Websockets API).