Hemi Mainnet: Block Height Stalled at 2,814,124

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Oct 05, 2025 - 06:20 UTC

Monitoring

QuickNode teams have been working with the foundation team on this incident. The foundation team has mitigated this, and nodes have returned to the tip. We are continuing to monitor nodes.

We will provide the next update by 08:00 UTC or sooner.
Posted Oct 05, 2025 - 05:44 UTC

Investigating

The Hemi Mainnet is stuck at block 2,814,124.
Requests depending on new blocks may fail or return stale data.
QuickNode teams are investigating and will update with more information once it is available.
We will provide the next update by 08:00 UTC or sooner.
Posted Oct 05, 2025 - 04:19 UTC
This incident affected: Hemi (Mainnet - JSON RPC API, Mainnet - Websockets API).