XRPL Mainnet - Node Upgrade Required

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Dec 18, 2025 - 19:53 UTC

Update

We are continuing to monitor for any further issues.
Posted Dec 18, 2025 - 19:28 UTC

Monitoring

Engineers have applied updates and nodes are beginning to progress as normal.
Errors should now resolve and normal activity should continue without issue.

We continue to monitor for performance.
Posted Dec 18, 2025 - 18:45 UTC

Identified

We are currently upgrading our XRPL Mainnet `rippled` to 3.0.0 and `clio` to 2.6.0 following an amendment activation earlier today.

Users may experience "Amendment blocked, need upgrade" errors until the upgrade is complete.
We are actively working on this and will provide updates as we progress through the upgrade.
Posted Dec 18, 2025 - 17:38 UTC

Investigating

We are currently upgrading our XRPL Mainnet nodes to version 2.6.2 following an amendment activation earlier today. Users may experience "Amendment blocked, need upgrade" errors until the upgrade is complete. We are actively working on this and will provide updates as we progress through the upgrade.
Posted Dec 18, 2025 - 15:48 UTC
This incident affected: XRP Ledger (Mainnet — JSON-RPC API, Mainnet — Websockets API, Mainnet — Streams, Mainnet — Webhooks).