BSC Mainnet Degraded Performance - FRA Region

Incident Report for Quicknode

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 09, 2026 - 00:49 UTC

Investigating

The Quicknode team is investigating degraded performance of BSC Mainnet in the FRA region. We will update this page as we acquire new information.
Posted Sep 08, 2026 - 23:37 UTC