Degraded Performance - Increased Timeouts on Multiple EVM Networks

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Jan 30, 2026 - 01:13 UTC

Monitoring

A fix has been implemented, and we are monitoring the results. Customers may notice a temporary increase in 429 and 5xx errors while the fix is deployed across all affected nodes.
Posted Jan 29, 2026 - 21:25 UTC

Update

The Quicknode team is investigating the increased timeouts on multiple EVM networks - we will update this page as we acquire new information.

Users may experience timeouts, empty/null, and other unexpected RPC responses.
Posted Jan 29, 2026 - 20:56 UTC

Investigating

The Quicknode team is investigating the increased timeouts appearing on multiple networks - we will update this page as we acquire new information.
Posted Jan 29, 2026 - 20:53 UTC