Race Mainnet : Block height stalled at 14727418

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted Jun 15, 2025 - 01:19 UTC

Update

We are currently experiencing ongoing blockchain synchronization issues with the Rase mainnet. The network initially stalled, resumed processing, but has encountered another stall event and is currently stopped at block 14,730,023. Our engineering team is actively working with the Rase Foundation to investigate the root cause of these intermittent stalling issues and implement a resolution. We will continue to monitor the situation closely and provide updates as more information becomes available. We apologize for any inconvenience this may cause and appreciate your patience as we work to restore full network stability.
Posted Jun 14, 2025 - 09:29 UTC

Investigating

We are currently investigating this issue.
Posted Jun 14, 2025 - 06:30 UTC
This incident affected: RACE (Mainnet — JSON-RPC API, Mainnet — Websocket API).