Mantle Sepolia network wide being stalled at block 23526460

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted May 30, 2025 - 10:07 UTC

Investigating

We are currently investigating a block production issue affecting the Mantle Sepolia testnet. Block processing has stalled at height 23526460, preventing new transactions from being confirmed on the network.
Posted May 30, 2025 - 09:53 UTC
This incident affected: Mantle (Sepolia — JSON-RPC API, Sepolia — Websockets API).