Elevated 503 Errors - US-East Region

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Jul 09, 2026 - 05:30 UTC

Monitoring

The elevated errors affecting chains in the US-Region has been addressed. Our team is monitoring for stability.
Posted Jul 08, 2026 - 18:37 UTC

Identified

We have identified the root cause of the elevated 503 errors in the US-East region. Our engineers are actively working on recovery. We will continue to monitor and provide updates as the situation progresses.
Posted Jul 08, 2026 - 18:11 UTC

Investigating

We are investigating elevated 503 errors affecting our US-East region. Multiple chains may be impacted. Our team is actively investigating and will provide updates as more information becomes available.
Posted Jul 08, 2026 - 17:22 UTC