Injective Mainnet- Network Upgrade v1.18.2

Incident Report for Quicknode

Resolved

The Injective mainnet upgrade to v1.18.2 has been completed successfully. INJ endpoints are fully operational.
Posted Mar 09, 2026 - 16:48 UTC

Investigating

INJ endpoints may experience brief disruptions due to an upcoming mandatory Injective mainnet upgrade to v1.18.2. We are actively tracking the upgrade block height and will provide timing details as soon as they are confirmed.
Posted Mar 09, 2026 - 14:04 UTC
This incident affected: Injective (Mainnet Tendermint JSON-RPC/REST API, Mainnet Cosmos gRPC & REST API, Mainnet — Streams, Mainnet — Webhooks).