Billing Dashboard Metrics Delayed

Incident Report for Quicknode

Resolved

The incident has been resolved. The Billing Dashboard Metrics are now operating normally. We will continue to monitor the situation and apologize for any inconvenience caused.
Posted May 23, 2026 - 20:31 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 23, 2026 - 19:20 UTC

Investigating

We are investigating an issue causing billing metrics on the dashboard to appear delayed. We will provide updates as more information becomes available.
Posted May 23, 2026 - 15:57 UTC