Hyperliquid Mainnet - Increased Latency

Incident Report for Quicknode

Resolved

The elevated latency issue affecting Hyperliquid Mainnet has been resolved. All systems are operating normally. We will continue to monitor for any recurrence.
Posted Sep 16, 2026 - 19:12 UTC

Investigating

We are investigating increased latency of Hyperliquid Mainnet - we will update this page as we acquire new information.
Posted Sep 16, 2026 - 19:03 UTC