Block Height Stall: Polygon zkEVM-Mainnet

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted Oct 28, 2025 - 02:49 UTC

Monitoring

Polygon zkEVM-Mainnet nodes are progressing once again and have synced to the tip of the chain.
No further impact is expected; we will provide another update within 10 minutes once a full resolution has been confirmed.
Posted Oct 28, 2025 - 02:40 UTC

Investigating

Our team recently identified a stall at block #26,719,487 on Polygon zkEVM-Mainnet.
We are actively investigating and will provide another status update by 02:45 UTC
Posted Oct 28, 2025 - 02:05 UTC
This incident affected: Polygon zkEVM (Mainnet — JSON-RPC API, Mainnet — Websockets API, Mainnet — Streams, Mainnet — Webhooks).