Polygon Amoy — Elevated Errors During Foundation Stress Test

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Jun 04, 2026 - 06:14 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 04, 2026 - 04:15 UTC

Investigating

We are aware of elevated API errors and 503 errors on Polygon Amoy. The Quicknode team is actively investigating. We will provide updates as this progresses.
Posted Jun 03, 2026 - 23:57 UTC

Monitoring

The Polygon Amoy nodes are recovering following the network stress test. We are monitoring for stability.
Posted Jun 03, 2026 - 20:52 UTC

Investigating

We are aware of elevated API errors and 503 errors on Polygon Amoy. The Polygon Foundation is currently conducting a network stress test which may be contributing to degraded performance. We will provide updates as this progresses.
Posted Jun 03, 2026 - 18:12 UTC
This incident affected: Polygon (Amoy — JSON-RPC API, Amoy — Websockets API, Amoy — Webhooks, Amoy — Streams).