Sui Mainnet Network Stalled at Block 280,692,037

Incident Report for Quicknode

Identified

The Sui Foundation has acknowledged the issue and is actively working on a fix. We will continue to provide updates as more information becomes available.
Posted May 28, 2026 - 16:01 UTC

Investigating

The Sui Mainnet network appears to have stalled at block 280,692,037. The QuickNode team is investigating and has raised the issue with the Sui Foundation. We will update this page as more information becomes available.
Posted May 28, 2026 - 14:15 UTC
This incident affects: Sui (SUI Mainnet — JSON-RPC API, Sui Mainnet - gRPC, Sui Mainnet - GraphQL).