Starknet Sepolia - Network-wide Stall

Incident Report for Quicknode

Resolved

The Starknet Sepolia network has resumed block production. Blocks are now progressing normally and customers should be able to query new blocks and submit transactions. We will continue to monitor for stability.
Posted Feb 11, 2026 - 14:33 UTC

Investigating

We are currently experiencing a network-wide stall on Starknet Sepolia at block 6418614. Customers will be unable to query new blocks or submit transactions until the network resumes block production. This is an upstream issue affecting the entire Starknet Sepolia testnet.
Posted Feb 11, 2026 - 14:30 UTC
This incident affected: Starknet (Sepolia — JSON-RPC API, Sepolia — Websockets API).