Degraded Performance - Solana Mainnet

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted Jul 02, 2025 - 19:13 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 02, 2025 - 18:41 UTC

Identified

This was local to APAC region Solana Infrastructure only. We identified a potential cause and are implementing measures to mitigate the issue.
Posted Jul 02, 2025 - 18:31 UTC

Investigating

The QuickNode team is investigating the degraded performance of Solana Mainnet- we will update this page as we acquire new information.
Posted Jul 02, 2025 - 18:22 UTC
This incident affected: Solana (Mainnet — JSON-RPC API, Mainnet — Websockets API).