Bitcoin Cash (BCH) Block Production Stall

Incident Report for Quicknode

Resolved

Bitcoin Cash (BCH) mainnet block production has resumed and the network is producing new blocks again. We will continue monitoring for stability.
Posted Mar 30, 2026 - 13:30 UTC

Investigating

We are currently investigating a block production stall on the Bitcoin Cash (BCH) mainnet. The network appears to have stopped producing new blocks, which is also confirmed by public explorers showing the same block height. We are monitoring the situation closely and will provide updates as they become available.
Posted Mar 30, 2026 - 11:53 UTC
This incident affected: BNB Smart Chain (BSC) (Testnet — JSON-RPC API, Testnet — WebSocket API, Testnet — Webhooks, Testnet — Streams).