Arbitrum Mainnet - Elevated 503 and API Errors

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted May 20, 2026 - 22:58 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 20, 2026 - 20:34 UTC

Investigating

We are investigating an elevated rate of 503 and API errors affecting Arbitrum Mainnet. Our team has identified an issue with backend connectivity and is actively working to restore full service. We will provide updates as more information becomes available.
Posted May 20, 2026 - 19:43 UTC
This incident affected: Arbitrum (Mainnet Nitro — JSON-RPC API, Mainnet Nitro — WebSocket API, Mainnet Classic — JSON-RPC API, Mainnet Classic — WebSocket API, Mainnet — Webhooks, Mainnet — Streams).