Stuck Network - Hemi Mainnet nodes stuck at block 3,755,492

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Feb 12, 2026 - 22:49 UTC

Investigating

Our Hemi Mainnet nodes have stalled at block 3,755,492 - The QuickNode team is applying fixes and will update with more information once it is available.
Posted Feb 12, 2026 - 21:58 UTC
This incident affected: Hemi (Mainnet - JSON RPC API, Mainnet - Websockets API, Mainnet — Streams, Mainnet — Webhooks).