Hedera Mainnet Network Stalled

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted May 20, 2026 - 19:07 UTC

Identified

Hedera Mainnet appears to have stalled at block 95,291,380. This is due to on-going maintenance by the foundation. You can find more details from the Foundation's Status Page here:

https://status.hedera.com/incidents/6558j95l840y
Posted May 20, 2026 - 18:02 UTC

Investigating

Hedera Mainnet appears to have stalled at block 95,291,380. This is due to on-going maintenance by the foundation. You can find more details from the Foundation's Status Page here:

https://status.hedera.com/incidents/t9d33l15ygv0
Posted May 20, 2026 - 17:24 UTC
This incident affected: Hedera (Mainnet - JSON-RPC API, Mainnet - REST API, Mainnet — Streams, Mainnet — Webhooks).