Polygon Amoy: Archive Nodes Stalled at Block 36,805,071

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Apr 17, 2026 - 23:01 UTC

Investigating

Polygon Amoy archive nodes are currently stalled at block 36,805,071. Requests for historical data following this block will result in 503s. Users querying tip data are not affected. Our team is actively investigating the cause with priority and we'll provide updates as new information becomes available.
Posted Apr 17, 2026 - 21:38 UTC
This incident affected: Polygon (Amoy — JSON-RPC API, Amoy — Websockets API, Amoy — Webhooks, Amoy — Streams).