Degraded Performance - Polygon Mainnet NRT Region

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Apr 22, 2026 - 21:15 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 22, 2026 - 15:33 UTC

Investigating

The Quicknode team is investigating the degraded performance of Polygon Mainnet in the NRT region - we will update this page as we acquire new information. Users may be served 503s at this time in the affected region.
Posted Apr 22, 2026 - 15:09 UTC
This incident affected: Polygon (Mainnet — JSON-RPC API, Mainnet — Websockets API, Mainnet — Webhooks, Mainnet — Streams).